Information

TweakPower Datenshredder

Sicheres Löschen Ihrer Daten

TweakPower Datenshredder bietet Ihnen eine einfache und effektive Lösung zum sicheren Löschen von Dateien: Sie wählen einfach die Dateien zum Löschen aus und auf Mausklick werden die Daten mehrmals überschrieben. Die Integration in den Windows-Explorer ermöglicht das einfache Löschen über das Kontextmenü – genau, wie Sie es vom normalen Löschvorgang her gewohnt sind.


Wichtige Hinweise

Wichtige Benutzungshinweise

Bitte beachten Sie, dass mit TweakPower Datenshredder gelöschte Daten nicht mehr wieder herstellbar sind! Stellen Sie bitte immer vor dem Löschen sicher, dass Sie entweder die Daten wirklich löschen wollen oder Sie die Daten an einer anderen Stelle durch eine Sicherungskopie gespeichert haben. Einmal gelöschte Daten können nicht mehr rekonstruiert werden!!!


Einführung

Wie werden Daten gespeichert

Wollen Sie Ihren alten Computer oder eine von Ihnen benutzte Festplatte verschenken, verkaufen oder einfach nur loswerden? In einem solchen Fall ist es notwendig, die auf den Datenträgern enthaltenen Daten komplett zu zerstören, um Ihre Privatsphäre zu schützen. Auch in Bezug auf den Datenschutz ist es gerade bei der Speicherung von vertraulichen Daten wie zum Beispiel Bankdaten, Kreditkarteninformationen, Betriebsdaten, Buchführungsdaten, Kundendaten oder Patientendaten dringend notwendig, diese Informationen vor der Weitergabe, Verkauf oder der Entsorgung des Datenträgers unwiderruflich zu zerstören. Es ist nicht möglich, alle vertraulichen Daten aufzuzählen, die unter keinen Umständen in fremde Hände geraten sollten.

Weit verbreitet ist der Glaube, dass eine Neuformatierung der Festplatte mit den Befehlen FORMAT oder FDISK die Daten unwiederbringlich löscht. Doch Datenbestände, die auf diese Art und Weise gelöscht wurden, sind selbst von PC-Laien mit den entsprechenden Software-Werkzeugen leicht wiederherzustellen.

Der Hauptaspekt besteht darin, daß ein Betriebssystem wie z.B. Windows die Informationen einer Datei nicht vollständig und unwiderruflich von der Festplatte löscht. Stattdessen wird der Name der gelöschten Datei, die sich in der Dateizuweisungstabelle (FAT) befindet, mit einem besonderen Zeichen versehen. Unter dem FAT-Dateisystem besteht dieses Zeichen als ASCII-Symbol 229 (0xE5), unter NTFS gelöschte Dateien besitzen in ihrem Header ein spezielles Attribut. Die angeblich gelöschte Datei wird somit für den Benutzer lediglich unsichtbar. Die Cluster, die die Datei eigentlich enthalten, werden als "frei" betrachtet. Der eigentliche Inhalt und sogar fast der komplette Dateiname bleiben bis zum erneuten Speichern von Daten auf diesem Cluster rekonstruierbar. Somit ist es ein leichtes, diese Datei wiederherzustellen.

Weder das Löschen von Partitionen noch das Formatieren des Datenträgers lösen das Problem dauerhaft. Wenn Partitionen einer Festplatte gelöscht werden, geht die Information der Partitionstabelle oder die der Dateizuweisungstabelle (FAT) verloren. Allerdings bleiben die Informationen, die sich in den Sektoren befunden haben, völlig unberührt, so daß sie auch in diesem Fall fast mühelos wiederhergestellt werden können. Selbst beim Low-Level-Format lässt sich noch auf einen sehr großer Teil der Daten zurückgreifen. Dieses Problem kann nur durch spezielle Löschverfahren behoben werden.


Schnelles Überschreiben

Schnelles Überschreiben

Einmaliges überschreiben der Datei mit Zufallswert. Keine Wiederholung möglich. Schnellste Methode.


U.S. Standard, DoD 5220.22-M (E)

U.S. Standard, DoD 5220.22-M (E)

Basierend auf dem "National Industrial Security Program Operating Manual" (NISPOM) der NSA vom Januar 1995, verwendet dieser Lösch-Algorithmus drei Schreibdurchläufe:

1. Durchlauf: überschreiben mit fest vorgegebenem Wert
2. Durchlauf: überschreiben mit Zufallswerten
3. Durchlauf: überschreiben mit dem Komplementwert des ersten Durchlaufs

Dies ist der gebräuchlichste Algorithmus, den man in nahezu jedem Löschtool vorfindet. In den Bestimmungen NTSC-TG-025 des US-amerikanischen Verteidigungsministeriums wird ausdrücklich darauf hingewiesen, dass das Löschen von Informationen mit der militärischen Einstufung "Secret" oder "TOP-Secret" mit diesem Verfahren nicht erlaubt ist. Für den Heimgebrauch aber sicher ausreichend.


Russischer Standard

Russischer Standard, GOST P50739-95

Die russische GOST-Norm p50739-95 (GOST=gosudarstvennyj standart) von 1995 verlangt für das Löschen von Daten der Sicherheitseinstufung sechs bis vier lediglich das einfache Überschreiben der Sektoren mit dem Wert 0x00 und in der Sicherheitseinstufung drei bis eins das einfache Überschreiben der Daten mit einem zufälligen Wert. Dieses Verfahren kann als nicht sicher angesehen werden.


DoD 5220.22-M

U.S. Standard, DoD 5220.22-M (ECE)

Dies ist eine Variante des DoD 5220.22-M mit sieben Durchläufen, wobei die Daten zunächst mit den drei Durchläufen des DoD 5220.22-M (E) Standards, anschließend mit einem Zufallswert, danach erneut mit den drei Durchläufen des DoD 5220.22-M (E) überschrieben werden.


Deutscher Standard

Deutscher Standard, VSITR

Beim VSITR-Standard (Richtlinien zum Geheimschutz von Verschlussachen beim Einsatz von Informationstechnik), herausgegeben vom Bundesamt für Sicherheit in der Informationstechnik (BSI), werden die zu löschenden Daten bei insgesamt sieben Durchläufen in den ersten sechs Durchläufen abwechselnd mit den Werten 0x00 und 0xFF und im letzten Durchlauf mit dem Wert 0xAA überschrieben.


Peter Gutmann

Peter Gutmann

In seinem Aufsatz "Secure Deletion of Data from Magnetic and Solid-State Memory" erläutert Peter Gutmann 1996 ein Verfahren zum Löschen von Daten auf verschiedenen Medien. Dabei werden alle bekannten Bitmuster, die zur Speicherung auf der Festplatte verwendet werden können, nacheinander geschrieben und somit das analoge Signal derart verrauscht, dass eine Rekonstruktion der Daten so gut wie unmöglich ist. Es ist durch seine 35 Durchläufe sehr zeitintensiv, wird jedoch als äußerst sicher angesehen.


wipefreespace

Daten nachträglich sicher löschen

In den Kontextmenüs von Laufwerken wie "C:" erscheinen zwei Optionen.. Zum einen lässt sich darüber die gesamte Partition (also nicht zwingend die gesamte Platte) leeren. Sehr sinnvoll ist außerdem die Option "Freien Speicher sicher löschen". Hierbei werden alle nicht belegten Datenbereiche einer Partition inklusive der in der Vergangenheit unsicher gelöschten Daten gesäubert. Gelöschte Dateien sind nicht wirklich gelöscht. Der Bereich, in dem die Daten liegen, wird vom Betriebssystem als frei markiert und kann deshalb für neue Dateien vergeben werden. Wenn dies aber nicht geschieht, dann können diese Daten aufgespürt und ausgelesen werden. Deshalb sollten Sie diesen freien Speicherplatz mit der Option "Freien Speicher sicher löschen" überschreiben.

Der Lösch-Algorithmus verwendet hierbei drei Schreibdurchläufe:

1. Durchlauf: überschreiben mit fest vorgegebenem Wert
2. Durchlauf: überschreiben mit dem Komplementwert des ersten Durchlaufs
3. Durchlauf: überschreiben mit Zufallswerten

HINWEIS: Es werden hierbei keine existierenden Dateien oder Daten gelöscht, sondern lediglich die als frei markierten Bereiche der Festplatte überschrieben. Nach Beenden dieses Vorgangs können Sie keine gelöschten Dateien rekonstruieren! Der Papierkorb sollte vorher geleert werden

.